Can not download data from ISIC using filters

Hello, I have a problem trying to download data from ISIC gallery. I used to have the option to download the data when I selected the filters but, since a month ago, the option is not avaible for me anymore. Is this related to an authentication problem or it is because of the live ISIC challenge? Thanks in advance :slightly_smiling_face:.

The bulk download functionality is temporarily offline while we transition to a new API. The new API is online but isn’t particularly well documented at the moment, the /images/search endpoint here is probably what you’re looking for:

It supports various filters e.g.:

Display images diagnosed as melanoma from patients that are approximately 50 years old.
age_approx:50 AND diagnosis:melanoma

Display images from male patients that are approximately 20 to 40 years old.
age_approx:[20 TO 40] AND sex:male

Display images from the anterior, posterior, or lateral torso anatomical site where the diagnosis was confirmed by single image expert consensus.
anatom_site_general:*torso AND diagnosis_confirm_type:"single image expert consensus"

Additionally, there’s a CLI that’s experimentally supported here: It would support those types of searches as well, so isic image download --search 'diagnosis:melanoma' images/ would download all instances of melanoma to your images/ directory.

Finally, prepackaged sets of data are available for all of the past challenges at

1 Like

Hello again. I tried to apply the filters in the new API, however, it only has the option to download individual images. I want to get a big amount of images and could not download them one by one because this would be a long process. I would like to ask for more detailed instructions to achieved this. By the way, I can not use the ISIC Challenge datasets due to specific filters that I must take into account. If the new API is not able to bulk download, I would like to know when is it going to be reactivated in the ISIC gallery page. Thank you in advance for your help.

Did you try using the CLI?

Yes, but I kind of have a problem with it. I installed the CLI and tried to execute the isic user login, however, the command line throws a “isic it is not recognized as a internal or external command” message. I thought it was an installation problem but I tried with the pip list command and the isic-cli appears as one of the installed packages. I would like to ask you for help on this issue and apologize for the inconvenience, I am new in this topics.

1 Like

me too!!

The problem is that the package is installed but your terminal can’t find it. If you can specify the full location to it it should work.

Assuming you’re on Windows, if you run pip show isic-cli it should show the location it was installed in e.g. c:\users\foo\python\site-packages. Replacing site-packages with scripts should work, so in this example the final path would be c:\users\foo\python\scripts\isic.

So instead of running isic user login you would run c:\users\foo\python\scripts\isic user login.

We have something planned in the future that should hopefully make this much easier, but for now this is the workaround.

1 Like